Elektroda.com
Elektroda.com
X

[Solved] Philips 42pfs4012 - Fails to boot.

435 7
  • Level 3  
    Hello, does anyone have the dump for a Philips 42pfs4012/12?
    The main board is a TP.MS3463S.PB801 and the panel is k420wdkb
    I've tried some dumps from some 40" and the TV starts but the picture isn't right.
  • Level 3  
    Unfortunately it doesn't work, the TV boots but the image is not right and is upsidedown too
  • Level 3  
    No, non va.

    With this last firmware the screen seems to be ok but it doesn't fully boot just like the fw it came with.
    The Philips logo appears, then the bottom osd with the channel informations starts flashing on and off, the TV won't accept any command.
    With the first firmware linked the TV works: I can enter the menu, change channels etc..the screen is flipped tho.
  • Level 3  
    querij wrote:
    Try to update the firmware


    MY DUDE! Fixed.
    Ok, the update did the trick.
    I'm gonna indicate 2 ways to fix this tv:
    1) In case the 25Q64 is good, like mine is, but compromised it is necessary to only copy the update file on an USB drive, plug it in and then plug the tv in. If the standby led stays red press power and wait: the led fill flash slowly and then faster, in my case it never stopped flashing fast so I unplugged the TV from the AC. At reboot the TV worked.

    2) This could be helpfull for other TV aswell.
    I had the "wrong" firmware on the 25q64, the onle linked before. The tv started, image was flipped and wrong, remote worked partially.
    You can press Menu (either on the remote or the tv) and then 1147 to enter service menu, in there you can enable mirror mode and change PANEL SETTING => Preset Panel ID so the image looks fine. In there you can also see what the update file should be named so the tv updates itself on boot, this information is located in the System info menu alongside with the board model and panel model the software is designed for.
    I renamed the update file from what it was to what this "wrong" software expected, it updated and at boot everything was set as expected for this tv, right panel, no mirroring, remote works.

    I've factory resetted the TV and copied the firmware; I'm attaching it for you guys to use.