Elektroda.com
Elektroda.com
X

Iveco daily - Iveco Daily 3.0 HPI 146 HP 2007 EDC blinks, engine indicator light

13083 5
This content has been translated » The original version can be found here
  • Level 7  
    Hello, I have a problem with iveco daily 3.0 hpi 146 KM 2007 tinplate max. Second EDC indicator light and engine indicator light yellow no power is a symptom, I was on computer diagnostics and shows the error:
    134 - air pressure sensor
    - Below the maximum threshold
    -present
    this is my description, the problem is that none of the air sensors is damaged and we can't find the reason, and the computer flashing EDC shows nothing and I don't know what the problem is, if someone had a similar problem, please help
  • Level 13  
    I have the same problem you know what you need to do
  • Level 8  
    31396 wrote:
    Hello, I have a problem with iveco daily 3.0 hpi 146 KM 2007 tinplate max. Second EDC indicator light and engine indicator light yellow no power is a symptom, I was on computer diagnostics and shows the error:
    134 - air pressure sensor
    - Below the maximum threshold
    -present
    this is my description, the problem is that none of the air sensors is damaged and we can't find the reason, and the computer flashing EDC shows nothing and I don't know what the problem is, if someone had a similar problem, please help


    I had the same .. start with the "boost pressure sensor" such a barrel attached (looking under the hood on the left at the height of the radiator base) as long as I remember correctly two two connections - hoses on the top and probably a cube with electricity. - it is about 5-8cm high - looks like a mini fuel filter :)
    By the way, I replaced the throttle for this new generation (flawless 700 PLN) plus a new cable (120) After replacing the aforementioned Check + EDC part it went out for good. I will add that these lights have been lit for me from the beginning - I made the change at 350,000 thousand and today I have 540,000 and so far there is no trace of the controls :)
  • Level 8  
    It depends what you ask. if the throttle is on the opposite side - you show the left side and it is on the right side of the engine - a little deeper if I remember correctly - behind the engine cover.
    I immediately say that cleaning will not do anything .. the problem with these dampers is at the electronic level - from what I read the factory defect, while the newer generation dampers are improved in this respect and as I wrote in the earlier answer after replacing with a new one the problems with controls. I have made over 200,000 thousand km and the problem does not return.
    However, I would start with this controller at the radiator attachment - on the left.
  • Level 8  
    BiggSizze wrote:
    It depends what you ask. if the throttle is on the opposite side - you show the left side and it is on the right side of the engine - a little deeper if I remember correctly - behind the engine cover.
    I immediately say that cleaning will not do anything .. the problem with these dampers is at the electronic level - from what I read the factory defect, while the newer generation dampers are improved in this respect and as I wrote in the earlier answer after replacing with a new one the problems with controls. I have made over 200,000 thousand km and the problem does not return.
    However, I would start with this controller at the radiator attachment - on the left.



    I do not know if the topic to warm up, but I will ask - what number has a "newer type" damper ?? Perhaps, how is it different from the faulty one? I have to change at home and I don't know what to buy ....: /