Elektroda.com
Elektroda.com
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.com

The Vag KKl cable does work with the vcds program.

TomiPl12 21369 11
This content has been translated » The original version can be found here
  • #1
    TomiPl12
    Level 6  
    Hi, I have a vagkkl cable and software for cars not younger than 2004 and I would like to know if I could make the soft VCDS 12.12 work with the vagkkl cable? Is it enough to install some drivers for the cable?
  • #2
    r_Lunar
    Level 9  
    vag kkl is for cars younger than 2005, usually, as the name says KKL, from the K-line. cars after 2004 had more and more CAN, and in the audi after 2006, your cable will not do anything at all.
    and VCDS will not work with KKL, install VAG COM. The cable drivers should be supplied from the manufacturer. If you do not find it on the KKL cable in google, read the installation instructions!
  • #3
    TomiPl12
    Level 6  
    A vag com to which year the car will do the trick?
  • #4
    leonov
    Level 42  
    r_Lunar wrote:
    after 2006, your cable will not do anything at all.
    and VCDS will not work from the KKL
    Would it be for sure? link :idea:
  • #5
    r_Lunar
    Level 9  
    leonov wrote:
    r_Lunar wrote:
    after 2006, your cable will not do anything at all.
    and VCDS will not work from the KKL
    Would it be for sure? link :idea:


    Okay, I was thinking about VCDS for RossTech cables, I did not think about the Lite version, for example. And these cables from VAG COM work very steadily

    Added after 3 [minutes]:

    TomiPl12 wrote:
    A vag com to which year the car will do the trick?


    It is not important to vintage what the network in the car. Your cable works with, for example, Audi a4 b5, b6, a4 b7, unfortunately not especially from 2006. Tell me how you want to diagnose the cars in which yearbooks and, first of all, where did you buy the cable?
  • #6
    TomiPl12
    Level 6  
    I have long cables, and I do not mean vcds lite only the full version, the cars I want to service: a6 from 2009, passat b6 from 2006 and b8 from 2016
  • #7
    piotrekwoj1
    Level 39  
    TomiPl12 wrote:
    I have long cables, and I do not mean vcds lite only the full version, the cars I want to service: a6 from 2009, passat b6 from 2006 and b8 from 2016


    Forget about this equipment for sure.
  • #9
    grala1
    VAG group specialist
    You will not fire VCDS on KKL.
    VCDS requires a special interface that has a different construction.
    VCDS will not even notice your interface.
    Your interface does not support CAN and no software will change it.
  • #10
    motorek79
    Level 1  
    What is different from vcds, from vcds lite, since solid reads from kkl, it sees everything that lite allows.
  • #11
    arek600
    Level 2  
    good question too i have this problem and i would like to know the solution
  • #12
    marfur30
    Level 24  
    motorek79 wrote:
    What's the difference between vcds and vcds lite, since lite reads with kkl, sees everything that lite allows.


    The fact that Lite is soft for Vag-KKL and supports cars until 2005 that have diagnostics on the K and L lines. Newer models connect on the CAN bus that this cable does not support.
    For your cars you need to buy, for example, HEX-V2 or HEX + CAN.