Elektroda.com
Elektroda.com
X
Elektroda.com

The BMW E46 estate wagon does not work with the rear wiper and washer system

dj_master0 14094 12
This content has been translated flag-pl » flag-en View the original version here.
  • #1
    dj_master0
    Level 12  
    Hello, I have a problem with the bmwe46 estate, the rear scoop and the sprayer does not work. I crumpled plugs, cables and it does not work. Sometimes when I leave and the valves are closed, it will surprise and work for some time. Does anyone know which wirebag with a bunch of wires is from the wiping? Because I have 2 on the right and one on the left.

    Added after 35 [minutes]:

    I will add that the doormat is not obliterated
  • #3
    dj_master0
    Level 12  
    There is nothing in this manual on this subject
  • #4
    13Rycerz
    Level 8  
    And the meter? Turn on the wiper and check the voltage. Then turn off and check again where the signal will not be your wiper cable. Similarly with the washer. you check it all under the steering wheel. or when the cables are colored, look into the wiper and washer - check the color and the same under the steering wheel and then the cable to be replaced. It should help unless the fault lies elsewhere ...
  • #5
    dj_master0
    Level 12  
    I cleaned the rear squeegee, I unscrewed the whole mechanism, I greased everything because something worked hard. The squeegee works but I do not know why each time the ignition comes on, the moments come and go, then it works ok, and the sprayer still does not work.

    Added after 4 [minutes]:

    I would add that the mass of the wiper motor on the mechanism's casing was not leading, there are two blades that contact the mechanism housing, one in the motor and the other at the controller (black box) need to be cleaned. After this operation the wiper was working.
  • #6
    13Rycerz
    Level 8  
    This spontaneous inclusion may be caused by a short circuit / puncture
  • #7
    dj_master0
    Level 12  
    There is no tension on the spray pump, and the wiper will activate every time the key is turned. This stops as it pleases, later when it starts after the car has been started, it normally responds to the switch on the steering wheel.
  • #8
    Jackall
    Level 27  
    Replace the controller with the motor, it will start to operate normally the wiper and washer.
  • #9
    dj_master0
    Level 12  
    where will I buy such a driver?
  • #10
    Jackall
    Level 27  
    On the back with the motor, unless you hit damaged, you will only pay for the driver. But first, dismount your driver, maybe you can fix it.
  • #11
    Introwertyk6
    Level 8  
    Hello, I have the same problem as the author in E46 320d COMPACT
    The rear wiper has stopped coming back, it stuck ...
    I undressed the mechanism and, of course, the classic defect, the plastic wheel had molded teeth and the whole mechanism was heavily sated ... The gear I bought new >>>
    http://allegro.pl/bmw-e46-compact-silniczek-w...DQ2ZWM2YTA4MTIwOGYwYmYzMzEyOTU2OTY0NWU1MTE%3D

    I cleaned everything, put on grease, moved it and put it together ...
    It works!

    But not completely...
    When the ignition is switched on, from the position of the switch on the steering wheel, the wiper turns on and the engine performs several movements like the washer and sometimes stops in a different position than the starter, moreover the washer pump does not work (the beam does not give tension) Everything worked properly before pulling out .. .

    Conclusion ... Module (driver which I took out with the mechanism) I checked to the exact, the plate is clean and perfect, nothing got there ... I cleaned the contact not yet conductive and I got on once again convincing that this element is ok, but the problem continues ...
    The wiper turns on when the ignition and the washer pump nothing ... Using the handle on the steering wheel to the first position, i.e. one passing the wiper also turns it on for several cycles (like for the washer)

    Does anyone have an idea what to do? I can not find the driver itself anywhere, everywhere with the whole mechanism it is and I do not have to check another ... In the eventuality I suspect the comfort module (but also looked ok and would not break down in just one day while removing the rear wiper mechanism) .

    The only thing I've done is this mechanism ...

    On this plastic wheel (original) there was a small magnet, on the replacement there is no place for it, I do not know why it was to be used ... Or holding the wheel into the casing or maybe something with electrics?

    I am asking for help, symptoms identical to the author's ...

    Maybe someone has the same car and lend it to its driver to check?
  • #12
    Introwertyk6
    Level 8  
    Anyone have any idea suggestion? Maybe this module has been reset and it somehow sets?
    It's not possible that I damage it ...: /
  • #13
    aarahon
    Level 1  
    Introwertyk6 wrote:
    The wiper turns on when ignition and the washer pump nothing ...


    Hello, if so, how did you solve your problem?

    Because what the quote is is not a matching gear.

    The gear wheel for BMW E46 Compact is only one and does not fit other models due to:
    a) another place to attach the magnet to the sensor - on the wheel you bought is blinded, you need to cut the mandrel which is in the magnet holder and insert it as on the original wheel, then the wiper controller will adapt but:
    b) the wiper bolt spindle spacing is different, the magnet mounting place is also different so the wiper has a much greater movement which causes the wiper to slide down on the flap.

    You can try wiper transplant from focus mk1 before lift (only hatchback) but we lose the washer in the wiper arm.

    Anyway, let me know how it went.