Elektroda.com
Elektroda.com
X

TERMET G19-02 problems with main burner ignition

2256 12
This content has been translated » The original version can be found here
  • Level 3  
    Hello!

    I am the owner of the TERMET G19-02 Electronic gas water heater.
    Some time ago, there were problems with the main burner lighting. The ignition pilot works, of course, it is cleaned. Replacing the battery did not solve the problem.
    To start this stove, you need to turn off the warm water and lightly tap (set in vibrations) the tube that reaches the stove.
    I measured the coil voltages.
    Coil (orange) - 1.1V
    Coil (green) - if it does not fire, 0.01V, after switching off the stove and tapping 1.1V.

    Here I found the service manual http://www.tukado.pl/file/electronic-aquapower.pdf
    Will it be the fault of the coil or is the problem deeper because it does not get voltage?
  • Level 34  
    What tube are you writing about?
    Check that the detection electrode is clean, including the entire cable to the controller.
    If the electrode does not confirm the presence of a flame on the remote control, the controller will not allow you to turn on the main burner.
  • Level 2  
    I have a Demrad water heater in which, despite the battery being replaced, the magneto does not work. I observed an interesting thing, namely on previous batteries the sparker gave a spark despite the twisted water. What could be the reason?
  • Level 34  
    If the spark gap gives the spark all the time when the valve is closed, the needle in the water unit acting on the microswitch or the microswitch itself is damaged.
    Depending on how it is included in the control system, in extreme cases it may even be a damaged module.
    If after replacing the battery the stove does not work, I would start by checking the correctness of battery insertion.
  • Level 3  
    I apologize for the late reply, but I was still waiting for the battery to be replaced because it was getting worse.
    I meant a tube that brings water to the junkers. It is next to the spark generator. TERMET G19-02 problems with main burner ignition
    The metering electrode has been cleaned.
  • Level 34  
    The coil is not guilty of not getting voltage. Because if it doesn't get voltage, it won't open the valve.
    Check for loose cable or temperature sensors.
    one is attached to the heater (heat exchanger) and the other is the chimney draft sensor or rather its lack.
    If you have a meter, check if one of these sensors is not open when the stove does not want to ignite the main burner.
  • Level 3  
    I could not find out how these sensors work (resistance will increase?). After disconnecting the sensors, it does not fire, and after bridging there are sometimes problems with firing. Of course, I removed bridging.
    I will add that I once had a similar problem as @R ... : the magneto worked all the time, even after switching the microswitch. Only pulling out the battery worked for a long time.
  • Level 34  
    Temperature sensors are contact.
    After exceeding the appropriate temperature, the contact inside them opens and breaks the circuit.
    If the bridging did not permanently fix the problem, either the connector on the module or the problem is inside the module itself.
  • Level 3  
    Module or spark generator?

    The only thing that puzzles me is the fact that tapping on the stove goes out solves the problem.
  • Level 34  
    The module is not just a spark generator.
    Inside is the electronics of the flame presence sensor connected to a monitoring electrode, systems controlling solenoid valves and controlling the degree of battery wear.
    If as you write when you tap or right into the vibrations, the problem disappears, it means that somewhere there is something loose, no contact.
    Unless the information you provided at the very beginning is incorrect and the problem is mechanical in nature associated with the gas unit.
  • Level 3  
    I meant that under this name "spark generator" they sell this module. I understand why this is an electronic problem. I repeated the measurements, in fact there is no voltage on the coil. I will probably make one more connection with the dosing electrode again, because the cable was short and the service technician has blocked it.
  • Helpful post
    Level 34  
    It would be most convenient to replace the module for testing and then we would have confidence in what is damaged.
  • Level 3  
    This will be the best idea, because after making a solid connection with the electrode, there are still problems. I'll let you know.