• #1
    Level 3  
    I flashed 16A smart switch according to the guide here:


    The switch is working fine but I need to use the command "addClockEvent".

    Therefore, I added this to my autoexec.bat.

    startDriver ntp
    ntp_setServer 0.kr.pool.ntp.org
    ntp_timeZoneOfs 9:00

    However, I do not think the relay has the correct time because the relay cannot connect to NTP servers.

    Log repeatedly shows the next line

    Info:NTP:NTP_CheckForReceive: Error while receiving server's msg

    I tried different NTP servers but I got the same result.

    UI shows "NTP: Syncing with 0.kr.pool.ntp.org...." like below.

    NTP server and time sync with OpenBeken

    I tired the command "addClockEvent" and the relay would not turn on or off at the specified time.

    I think this is because the relay cannot sync with the NTP servers. Therefore, I have to figure out the time stored in the relay.

    Tasmota has the command "time" and the current time will be shown on the console when the command is issued.

    Is there any command or way to see the time or manually set the time?

    I went through the date command list but I could not find any.

    Any help is appreciated.
  • #3
    Level 3  
    IP address works!

    I have another question.

    I used the commands below to change the label of UI button.

    startDriver cmd_channels
    SetChannelLabel 1 Power

    However, while the button still has "Toggle", so it is now "Toggle Power".

    Is there any way to remove "Toggle" from the UI buttons?
  • #4
    Moderator Smart Home
    Well, right now not... but I can add a flag for that for you... some kind of a simple setting, wait...

    btw what is "cmd_channels"? I don't think anything like that exists.

    Added after 1 [hours] 7 [minutes]:

    @patentjyp I have added ability to hide "Toggle "prefix from button per your request.
    Please see updated docs for usage:
    Please search for "SetChannelLabel ". Of course, you must first update your firmware.
  • #5
    Level 3  
    It works! No "Toggle"

    Thank you again!!!
  • #6
    Moderator Smart Home
    It was a pleasure to help you. Is there anything else I can help with, or maybe do you have any other suggestions for console commands and/or fixes?