Elektroda.com
Elektroda.com
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.com

We are building our own NAS server

kassans 37077 128
This content has been translated » The original version can be found here
  • procsa
    Level 30  
    Well, I thought, especially that with the bios turned on, this pentium heats up, and unfortunately there is no option to lower the clock at all, only one thing that this motherboard has are two gigabit ports, but there would probably be a problem with using two hosts at full speed .
  • Karaczan
    Level 41  
    And I am currently testing a NAS based on Odroid XU4 and in general I am pleasantly surprised by the performance of this board.
    USB3.0 bay drive, EXT4 file system, smiga is on average 96-105MB / s in samba.
    And it cuts about 10W :D
  • Grzegorz1893
    Level 1  
    Hi to all.

    In order not to open a new topic, I will write my server configuration to us and I am asking you for help if everything is ok.

    It is to be used for backup of photos and videos, Windows 10, TeamSpeak 3 server for a few people, movies and possibly something more for the future, but you will probably need to upgrade. Generally 2-3 people can use at the same time.

    System : unRAID
    Processor: Intel Pentium Gold G5400 with the possibility of upgrading to i5-9400T or stronger with the designation T.
    Motherboard : Gigabyte B365M D3H
    RAM: 16GB DDR4 2666Mhz or more PUSKILL brand (Chinese good ram)
    Disk: Seagate SkyHawk 2TB 3.5 5900 (ST2000VX008) 2 pcs.
    Power Supply: SilentiumPC Elementum E2 SI 350W (SPC19)
    Cooling: SilentiumPC Fera 3 HE1224 v2 (SPC144)
  • pawelr98
    Level 39  
    Recently, I bought an FSP300-60EGA, i.e. a power supply with 80+ Gold.
    According to the test from the 80+ certification site, the efficiency for 115V is about 89%, so for 230V it will be 90 +%.
    A new one with a guarantee costs PLN 60.

    Relative to the previous power supply, a real improvement of some 12-13% was measured.

    The time will come to modernize the processor and the board in order to cut the power consumption more neatly.
    And then maybe you will look for some "civil" RAID controller, which is not so annoying.

    At the very end, there will be hard drives where there will be a replacement of all 2TB to 4TB or a change to 4x8TB in RAID10.

    Currently, the first "civil" switch for 2.5 Gbit / s technology has been released on the market.
    https://www.anandtech.com/show/15916/at-last-...k-switch-qnap-releases-qsw11055t-5port-switch
    It costs $ 100.

    A bit expensive, while the 2.5Gbit / s network cards on the PCIE are cheap because the cheapest PLN 60.
    Wiring may still be good old CAT5E.

    I have CAT6, I am waiting for competition with cheaper switches to appear and then I will replace the main switch.
  • orlicki12
    Level 5  
    How do you share files over the internet? I am currently trying to play with Nextcloud, but in conjunction with Letsencrypt unfortunately I cannot connect to the service locally only from outside the lan network. Probably Funbox's fault.
  • gimbus
    Level 12  
    Hello colleagues :-)
    And I took a different route - I tried earlier, I made a small 1-disk nasa from an HP terminal with a 2.5 "SATA disk inserted.
    It has proven itself over several years of work.

    We are building our own NAS server
    Later I got my hands on the disposal Netgear ReadyNAS NVX - a 4-disk solid mechanical construction. The investigation showed that the power supply is faulty.
    The original Netgear power supply available on Amazon costs half a fortune, and I wasn't sure if only this was damaged.
    After a short search, it turned out to be an ordinary PC power supply with the usual 20-pin motherboard connector, but the witty designers swapped
    a few pins in places. So I put a 24pin to 20pin power adapter into the housing with appropriately crossed cables:

    We are building our own NAS server
    The whole thing is not impressive, but it works and allows you to use a regular PC power supply:

    We are building our own NAS server

    I didn't like the original Netgear soft very much, so I built my own.
    I don't need the GUI and the gimmicks, I hate it when the device does something out of control and I don't know what's going on underneath, I prefer to have full control.
    The main task is backup, the rest are add-ons.
    My soft is not very friendly - the whole configuration has to be done from the console manually (vi or nano :-) ), but I know what's squeaking in the grass.
    I lost XRaid (Netgear's own idea) but replaced it with unionfs, which has pretty much the same effect - except manual configuration.
    Services available:
    ssh
    ftp / sftp
    www with CGI
    appletalk
    samba
    And of course, access via serial console ;-)
    Nothing prevents you from adding whatever your heart desires.
    The whole system boots to RAM, no element of it is placed on the matrix disks (unless expressly requested).
    To synchronize files with the computer I used the open source SyncThing program - amazing, it allows local and WAN synchronization, everything happens in the background.
    System boot screenshot below:
    Code:

    SYSLINUX 3.31 2006-09-25  Copyright (C) 1994-2005 H. Peter Anvin               
    Loading kernel..................................................               
    Loading rootfs.gz...............................................................................
    .......................................................................................................
    .....................................................................................................
    Ready.             
    �ahci 0000:03:00.0: masking port_map 0x7 -> 0x3                                 
    ln: /dev/log: Fidevpts: called with bogus options                               
    le exists                                                                       
    Starting syslogd                                                   OK           
    Starting acpid                                                     OK           
    Starting klogd                                                     OK           
    Starting mdev dynamic device management                            OK         
    Loading Kernel modules for LCD
    nvxgpio:                                                           OK
    Waiting for USB drive(s) to become ready..
    sd 5:0:0:0: [sde] Assuming drive cache: write through
    sd 5:0:0:0: [sde] Assuming drive cache: write through
    sd 5:0:0:0: [sde] Assuming drive cache: write through
    sd 6:0:0:0: [sdf] Assuming drive cache: write through
    sd 6:0:0:0: [sdf] Assuming drive cache: write through
    sd 6:0:0:0: [sdf] Assuming drive cache: write through
    Found 4 SATA drives and 2 USB drives:                            sde sdf
    Using external USB drive sdf
    Mounting /dev/sdf1 on /mnt                                         OK
    Creating temporary config dir on tmp                               OK
    Copying config files to temporary dir                              OK
    Copying config files to /etc                                       OK
    Initializing random number generator...                            OK
    Starting Auto assemble RAID
    Waiting for /etc/mdadm.conf to be restored
    Waiting for /etc/mdadm.conf to be restored
    /etc/mdadm.conf not found. Trying to auto-assemble
    Config updated
    Scanning Auto assemble RAID                                        OK
    Starting network:
    Bringing up interface lo                                           OK
    Bringing up interface eth0                                         OK
    Bringing up interface eth1                                         OK
    Bringing up interface bond0                                        OK
    Setting time zone to Europe/Warsaw
    Starting Network time protocol daemon                              OK
    Activating swap                                                    OK
    Starting Mount all storage devices
    Check if /dev/disk/by-label/BIGDATA exists                         OK
    Creating mountpoint /home:                                         OK
    Mounting BIGDATA (/dev/md1p1) on /home                             OK
    Setting options for /home:
        WARNING: Skiping option defaults                                   
    Check if /dev/disk/by-label/DATA0 exists                           OK
    Mountpoint /var/www exists
    Mounting DATA0 (/dev/sda3) on /var/www                             OK
    Setting options for /var/www:
        WARNING: Skiping option defaults                                   
    Check if /dev/disk/by-label/SMALLDATA exists                       OK
    Creating mountpoint /var/backup:                                   OK
    Mounting SMALLDATA (/dev/md0p1) on /var/backup                     OK
    Setting options for /var/backup:
        WARNING: Skiping option defaults                                   
    Changing mode to 0770                                              OK
    Changing group to 102                                              OK
    Starting Dropbear ssh server                                       OK
        Netatalk service - MacIntosh connectivity disabled in config       
    Syncing hardware clock with system clock:                          OK
        Cron scheduler daemon disabled in config                           
    Starting Smartd monitoring daemon                                  OK
        Hiawatha web server disabled in config                             
        Pure-ftpd sever disabled in config                                 
    Starting SMB service                                               OK
    Starting NMB service                                               OK
    Running all Local scripts (rc.local functionality)
        Absolutely useless front panel demo ;-) disabled in config         
    Starting Syncthing - continuous sync program                       OK


    +=====================================================+
    |           _                        __   _    __     |
    |    /\/\  (_)  ___  _ __  ___    /\ \ \ /_\  / _\    |
    |   /    \ | | / __|| '__|/ _ \  /  \/ ///_\\ \ \     |
    |  / /\/\ \| || (__ | |  | (_) |/ /\  //  _  \_\ \    |
    |  \/    \/|_| \___||_|   \___/ \_\ \/ \_/ \_/\__/    |
    |                        |
    |     by Szubi  (gimbus109@gmail.com)         |
    |        http://second.zmienneip.pl/hacking         |
    +=====================================================+

    bond0: 192.168.101.5
    eth0:
    eth1:

    MicroNAS login: root
    Password:
    # free
                  total        used        free      shared  buff/cache   available
    Mem:        2072440      135868     1351004           0      585568           0
    -/+ buffers/cache:       135868     1936572
    Swap:       4194296           0     4194296

    As you can see, the system is 135MB with 2GB in RAM.
    At the moment www, ftp and netatalk services are disabled in the configuration, but enabling them does not change the memory usage.
    The whole thing has been running for several months, but it is still "Work In Progress" -
    recently I added a menu that allows you to view important system status items on the LCD display - disk status and occupancy, RAID status, etc.

    I offer all kinds of assistance to those who are interested ;-)
    best regards
  • procsa
    Level 30  
    Buddy gimbus, great job, I admire and envy the abilities !!!

    Gentlemen, has anyone worked on xpenology and the Intel D2500CC boards? I have been tired for two days and I can not bet on this newer version than DSM 5.2, on any of the loaders from version 1.01 and above, I do not search for a server to install the PAT file, I replaced the files in the img image, etc. and nothing, on three other motherboards ( normal?) everything works flawlessly, but I also fail to start with the latest loader 1.03b.

    I found only one on the internet entry in Russian :

    Code: text
    Log in, to see the code


    Last sentence :

    -

    I can't speak Russian, so the translator explains:

    "There are no problems with the installation, just turn on the UEFI bootloader and disable the second LAN, register another Mac LAN in the rake."

    I understand everything, except the last words, change another MAC address, I do not know if this is the fault of the translator? But I tried different configurations with the MAC address of the card and random, but it did not work. Of course, I turned UEFI on (and off), and the second power cable also, no improvement; /

    There is Dual Gigabit 82574L on this Intel D2500CC motherboard
  • pawelr98
    Level 39  
    ????????? ? ????? ??? ??? ????

    The propisate is still raking the maklan

    So even without knowing the language, write down the MAC address in the rake.

    Sometimes it makes sense to use regular transliteration arrays instead of using a translator.
    Concepts related to computers are, like in Polish, taken straight from English, the translator will only confuse here.

    I, on the other hand, play other things.

    https://www.elektroda.pl/rtvforum/topic2155697.html

    I did this on my Gigabyte 870A-USB3 motherboard.

    The computer starts up perfectly without a graphics card, the operating system is reporting after SSH and I have not noticed any problems with its operation.
    Following the readings of the wattmeter, it can be concluded that the work of the graphics card is performed by the processor due to the lack of hardware acceleration on the part of the card.
    If the GUI is active, the power consumption drop is quite small.
    However, if we also switch to text mode (typical for Linux and other systems, not Windows), the decrease in energy consumption is more noticeable.

    In the case of the Ati X600 card, the difference between having and not having a graphics card in the system is approximately 5W in text mode and 2-3W in GUI mode. The difference between text mode and GUI is another few watts (regardless of card or no card).

    It is worth remembering about this patent not only for energy consumption, but also for the release of an additional PCIE port, which is sometimes important for mATX or ITX boards.

    Interestingly, some uefi motherboards can also move without any graphics card.
    It all depends on what the producer of the album came up with.
    However, it would be interesting to look for a similar permanent and relatively universal workaround for the uefi.
  • procsa
    Level 30  
    Thanks for the translation, I have a small request if someone explained to me in a simple way what I should do to start xpenalogy on my intel D2500CC, lan 82574L motherboard.
    I should install from the loader 1.02b (DS315), but from what I understand the drivers for my power cable are in the e1000e set, which, I'm not mistaken, are in the loader 1.03b from DS315, somewhere I read that I also changed the name to e1000 to make some Intel cards they worked, but I do not understand it, only as I wrote earlier there are entries that someone did it without any modifications on the same disc as mine, or on the same power cable.

    On loader 1.04 under DS918, LAN reports, gives an IP address and ping goes, but does not search for me in the synology program. In the 1.03b / 1.02b loaders, you can't see the card / disc at all.

    Anyone overwhelmed will help? I do not hide in these linux matters I am thin; / Below links to what bothers me.

    https://xpenology.club/compile-drivers-xpenology-with-windows-10-and-build-in-bash/

    https://xpenology.com/forum/topic/13922-guide-to-native-drivers-dsm-617-and-621-on-ds3615/

    https://xpenology.com/forum/topic/13333-tutorialreference-6x-loaders-and-platforms/

    https://xpenology.com/forum/topic/28321-drive...un-103b104b-for-dsm623-for-918-3615xs-3617xs/


    ps nice bios fun to save money! :)