[CB2S/BL0937] No name plug (QNCX) 20A (actually 16A relay)

GP007 915 11
This content has been translated flag-pl » flag-en View the original version here.
  • Plug purchased on ali in the promotion "3 items from" for 2.99 USD as 20A with energy measurement. The box is completely noname, there are also no inscriptions on the plug.
    Plus there are two diodes - blue for wifi, red for on / off.
    [CB2S/BL0937] No name plug (QNCX) 20A (actually 16A relay)

    [CB2S/BL0937] No name plug (QNCX) 20A (actually 16A relay)

    Link without promotion: link

    Initially I was going to use it with domoticz with Tuya plugin but curiosity prevailed.
    Attempts to upload via tuya cloudcutter failed.

    Demolition - practically damage-free with such a clamp:
    [CB2S/BL0937] No name plug (QNCX) 20A (actually 16A relay)

    Now I know that such sockets can be dismantled without much problem, only a moment of patience is required, i.e. 2-3 minutes :)
    [CB2S/BL0937] No name plug (QNCX) 20A (actually 16A relay)

    Inside there is a surprise: a 16A relay, the thickness of the solder and the PE cable is not great.
    I opened a dispute on ali and they gave back half the price without resistance.
    There we find the CB2S chip and the energy measurement using BL0937
    [CB2S/BL0937] No name plug (QNCX) 20A (actually 16A relay)

    [CB2S/BL0937] No name plug (QNCX) 20A (actually 16A relay) [CB2S/BL0937] No name plug (QNCX) 20A (actually 16A relay)

    I desoldered the CB2S for programming, the braid is necessary.
    Soft uploaded using BK7231 GUI Flash Tool - here I had a small problem at the beginning because WIN10 lost the drivers for CP2102 after the next update, but after realizing the situation it went without major problems.

    Configuration with the help of other topics from the electrode:

    P6 BL0937CF1
    P7 BL0937CF
    P8 LED (blue)
    P10 Btn
    P24 BL0937SEL
    P26 Rel (probably also a second red diode here)

    After calibrating with a 60W bulb that is actually 62W at 229V and a Fluke multimeter it seems to measure approx.

    Only with the OFF position there is a strange measurement instead of 0.

    [CB2S/BL0937] No name plug (QNCX) 20A (actually 16A relay)

    edit: Flag 38 helped with off measurement
    If there was such a plugin, please remove it, this is the third device on which I uploaded openbeken, previously two mini switches - one OTA, the other soldering.
    Thanks to the creator - respect!

    Cool? Ranking DIY
    About Author
    Level 7  
    GP007 wrote 10 posts with rating 6. Been with us since 2019 year.
  • #2
    Moderator Smart Home
    Hello, I see this is another LSPA9 style device. I often see such, but another review won't hurt, it's hard to judge what is what if the manufacturer does not sign the product.

    Strange measurements reported by BL0937 can be "cut" by turning on the appropriate flag, which resets them when the relay is open.
    I think I'll set it to on by default...
    38	[Power] Set power and current to zero if all relays are open

    Do you have maybe 2MB flash backup of this plugin?

    PS: Copy the template from Web App->Config, then it is formatted better.
  • #4
    Level 7  
    Ustawiłem flagę 30 [MQTT] Enable Tasmota TELE etc publishes (for ioBroker etc)
    i mimo wydania komend:
    VCPPublishThreshold 0.5 0.01 0.5 oraz VCPPublishIntervals 30 60
    średnio co 3 sekundy mam mqtt jak poniżej:

    tele/obk550A13C4/SENSOR {"Time":"2023-04-30T12:45:48","ENERGY":{"Power": 0.000000,"ApparentPower": 0.000000,"ReactivePower": 0.000000,"Factor":1.000000,"Voltage":239.068634,"Current":0.000000,"ConsumptionTotal":0.000000,"ConsumptionLastHour":0.000000}}
    tele/obk550A13C4/SENSOR {"Time":"2023-04-30T12:45:51","ENERGY":{"Power": 0.000000,"ApparentPower": 0.000000,"ReactivePower": 0.000000,"Factor":1.000000,"Voltage":237.840759,"Current":0.000000,"ConsumptionTotal":0.000000,"ConsumptionLastHour":0.000000}}
    tele/obk550A13C4/SENSOR {"Time":"2023-04-30T12:45:54","ENERGY":{"Power": 0.000000,"ApparentPower": 0.000000,"ReactivePower": 0.000000,"Factor":1.000000,"Voltage":239.314208,"Current":0.000000,"ConsumptionTotal":0.000000,"ConsumptionLastHour":0.000000}}
    tele/obk550A13C4/SENSOR {"Time":"2023-04-30T12:45:57","ENERGY":{"Power": 0.000000,"ApparentPower": 0.000000,"ReactivePower": 0.000000,"Factor":1.000000,"Voltage":237.717971,"Current":0.000000,"ConsumptionTotal":0.000000,"ConsumptionLastHour":0.000000}}
    tele/obk550A13C4/SENSOR {"Time":"2023-04-30T12:46:00","ENERGY":{"Power": 0.000000,"ApparentPower": 0.000000,"ReactivePower": 0.000000,"Factor":1.000000,"Voltage":237.104019,"Current":0.000000,"ConsumptionTotal":0.000000,"ConsumptionLastHour":0.000000}}

    Boje sie że mój broker mqtt tego nie wytrzyma.
  • #6
    Level 7  
    I tried TasTeleInterval 60 60
    but i get the answer:
    Error:CMD:cmd TasTeleInterval NOT found (args 60 60)
    unknown command
  • #7
    Moderator Smart Home
    Maybe you have too old version. Additionally, you need to run these commands on every boot, eg via autoexec.bat
  • #8
    Level 7  
    Thanks! I had version 1.17.11, after uploading 1.17.74 it's ok.
  • #9
    Level 32  
    GP007 wrote:
    The box is completely unnamed

    Try peeling off the sticker covering some of the markings.
    [CB2S/BL0937] No name plug (QNCX) 20A (actually 16A relay)
  • #10
    Level 2  
    I've bought similar plug on aliexpress. Paper box, looks the same, however the plug is signed as ELIVCO, model LSPA9. Interesting thing is, unlike to Elivco plug in other (
    p.kaczmarek2) posts, this one has CB2S module with Belon chip BL2028N inside, along with power metering chip BL0937.
    OpenBeken pinout is the same as the GP007 wrote in initial post. GP007 hank you for that!
    I have made successful backup via bk7231tools as well as via hid_download_py. hid_download_py program was significantly faster!
    Flashed OpenBK7231N_QIO_1.17.104, works just fine. Thank you mr p.kaczmarek2!

    Have just one pinout question. There is a Red LED which is in my case lighting all the time. I was wondering if it's possible to synchronize it with button (on/off)

    [CB2S/BL0937] No name plug (QNCX) 20A (actually 16A relay) [CB2S/BL0937] No name plug (QNCX) 20A (actually 16A relay) [CB2S/BL0937] No name plug (QNCX) 20A (actually 16A relay) [CB2S/BL0937] No name plug (QNCX) 20A (actually 16A relay)
  • #11
    Moderator Smart Home
    Good job! Remember also to try out our new flasher/configurator:

    You can just download it, and drag and drop your 2MB binary, and take a look:
    [CB2S/BL0937] No name plug (QNCX) 20A (actually 16A relay)
    See? We've got a config for your device.
    This tool can extract GPIO config from Tuya firmware, so you get working pinout for OBK.
    It's an experimental version, so double check it first, but it should be OK!

    Device configuration, as extracted from Tuya:
    - BL0937 SEL on P24
    - Button (channel 1) on P10
    - LED (channel 1) on P23
    - BL0937 VI on P6
    - WiFi LED on P8
    - BL0937 ELE on P7
    - Relay (channel 1) on P26

    Here is the same as OBK json:
    Code: json
    Log in, to see the code

    (generated here https://openbekeniot.github.io/webapp/templateImporter.html )

    Now, to your question - I don't know which is red LED. It may be the LED that is on P23, or a WiFi LED, that is on P8. It seems that they are both controllable. You can set the LED to the same channel as relay and it will follow the relay. You can also set LED_n role, which will mean that LED is on when relay is Off.
  • #12
    Level 2  
    Thanks a lot. You solved it.
    This pinout perfectly works for me:

    P6 BL0937CF1
    P7 BL0937CF
    P8 WifiLED //Blue LED
    P10 Btn (channel 1)
    P23 LED_n (channel 1) //Red LED lighting when relay is switched ON, not lighting when relay is switched OFF
    P24 BL0937SEL
    P26 Rel (channel 1)