Elektroda.com
Elektroda.com
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.com

DIY-A586 v1.6 by piotr_go

piotr_go 39231 224
This content has been translated flag-pl » flag-en View the original version here.
  • RM63
    Level 1  
    DIY-A586 v1.6 by piotr_go
    am i using the right program. I am using this rom Kick31.rom md5:e40a5dfb3d017ba8779faba30cbd1c8e
    I am using this patch kick31.patch
    my generate patch Kick31sd.rom md5:a94bd97701a8764b34c739c4ed6d5c61
    i can't create this MD:575c85b4119f913c64344e8022363d1b7

    where am i doing wrong
    Thanks in advance
  • TomekMierzwa
    Level 9  
    I guess the PFS problem is either a Cor or Path problem on Kickstart

    I have Minimig, Mista, Mister and there is no problem tutal it is enough to create a partition in PFS after the restart (SD boot attempt) causes guru
    Error 8000 0008 Task 0202A68 this problem does not occur in other Mist / Mister / Minimig systems and in real A600 / A500
  • piotr_go
    DIY electronics designer
    Guru failed to get PFS partition not detected.
    "TD64 Read" and "HD_SCSICMD Read (10)" are and are working.
    The same card under UAE works, so I think I set up the partitions correctly.
    I do not know...
  • TomekMierzwa
    Level 9  
    piotr_go wrote:
    Guru failed to get PFS partition not detected.
    "TD64 Read" and "HD_SCSICMD Read (10)" are and are working.
    The same card under UAE works, so I think I set up the partitions correctly.
    I do not know...




    For me, after creating a partition (WinUAE / Is DIY-A586) and loading FS pfs3aio 0x50465303, both LEDs light up red guru and reboot and over and over again when I change the type to FFS everything returns to normal, under WinUAE everything works OK. CPU 00 / FullECS

    Added after 2 [minutes]:

    I have a question about Next186 how to kill dos
    Image mounted to gotek (DOS 6.22 / 1.44 5.0 / 720 5.0 / 230) does nothing
    No Boot device available, waiting on RS232
  • piotr_go
    DIY electronics designer
    PFS3AIO can be loaded manually via mountlist, automation doesn't work yet.

    DIY-A586 v1.6 by piotr_go

    Check out this patch:
    https://github.com/piotr-go/FPGA/blob/master/...kick3.x%20sd%20patch%20(xdelta)%20v0.7.tar.gz

    TomekMierzwa wrote:
    I have a question about Next186 how to kill dos
    Image mounted to gotek (DOS 6.22 / 1.44 5.0 / 720 5.0 / 230) does nothing
    No Boot device available, waiting on RS232


    Next186 doesn't (yet) handle flopp.
  • TomekMierzwa
    Level 9  
    As for PFS, there is improvement
    No automount guru doesn't work yet :)

    I noticed one more error when I set up next partitions (no matter if PFS / FFS), mimi that I change the name to DH1, DH2, etc. in the program shows ok but in Workbench, for example, with CLI after assigning it is DH1GE_ME DH2GE_ME as if it did not delete characters
    It's OK under WinUae
  • piotr_go
    DIY electronics designer
    Yes, I connected to a PC and the file transfer worked.
  • TomekMierzwa
    Level 9  
    OK thanks. I will test, run pptp on Mikrotik via RS and try to run net.
  • piotr_go
    DIY electronics designer
    RM63 wrote:
    I am using xdelta gui but I get an error. Kick31.rom md5: e40a5dfb3d017ba8779faba30cbd1c8e my generate rom md5: a94bd97701a8764b34c739c4ed6d5c61 can't create this MD575c85b4119f913c64344e8022363d1b7 where am I doing wrong?

    Look for a ROM with MD5 = "e40a5dfb3d017ba8779faba30cbd1c8e"
    It won't work with another.
  • TomekMierzwa
    Level 9  
    Is there a minimum chance to accommodate this FPGA support for the 68020?
  • shafty
    Level 9  
    I still have a question if there is a chance to design an amiga splitter board on a different chip like the PIC16F15313 or at least in a housing other than smd. Currently, in Poland, PIC16F15313 on SO8 is bordering on a miracle (you would have to import from the states) and the protracted version can still be bought somehow. Possibly, the version on the atmegas that there is a lot on the market would also solve the matter (but here you would have to tinker with the software again and I suspect that the redesign of the board just to replace the chip with another socket would be simple.
  • TomekMierzwa
    Level 9  
    Someone may enlighten the question as to the validation of the system

    I have an SD card, I installed everything on WinUAE, everything worked fine, but after switching to the read error HDD disc
    It's OK again under WinUae
  • piotr_go
    DIY electronics designer
    TomekMierzwa wrote:
    Is there a minimum chance to accommodate this FPGA support for the 68020?

    0.1%
    FPGA too small.

    @shafty
    Must be PIC16F15313 because of the programmable mini logic it contains. The slinger itself is not used.

    TomekMierzwa wrote:
    but after translating to the board read error HDD

    Workbench error?
    Use some disk editor to see what the first sector of the card looks like.
    Or you'd better create a small image (~ 16MB) and send it.
  • piotr_go
    DIY electronics designer
    A colleague forgot about MaxTransfer = 0x1FE00
    :)
  • TomekMierzwa
    Level 9  
    OK, I am already correcting and testing further
    I forgot my PFS error



    I'm testing and I have a question
    I assume partitions, I set max transfer, I save (reboot)
    I fire up HDToolBox again, go inside and there again max transfer 0xFFFFF
    Is it supposed to be like that?
  • piotr_go
    DIY electronics designer
    TomekMierzwa wrote:
    I assume partitions, I set max transfer, I save (reboot)
    I fire up HDToolBox again, go inside and there again max transfer 0xFFFFF
    Is it supposed to be like that?

    Did you confirm the value after typing?
  • TomekMierzwa
    Level 9  
    Is there any keyboard shortcut (A + Ctrl + A)?

    Added after 9 [minutes]:

    OK. I put everything on a new one
    Checked 1FE00 for each partition set

    And after the reboot, anyway
    Workbench has read error

    New file for test

    http://tewait.com/elektroda/opis.zip
  • piotr_go
    DIY electronics designer
    Reset by push button only.

    I have just tested the workbench card installed under FS-UAE (linux) and everything works. I created partitions on DIY-A586.
    I don't know, I have no idea what could be wrong.

    Loading even a little or immediately error?
    Have you tried with one small partition? Let's say 256MB.
  • TomekMierzwa
    Level 9  
    OK. I will test it on a small one
    I think I found a problem
    This seems to be a problem after mounting PFS
    I will wait for PFS autoounting etc and for now I switched to FFS
  • shafty
    Level 9  
    Ok clear must be the PIC. Only if it could be the same PIC, but in a different housing. There are at least two stores where I can buy PIC16F15313 through-hole and not one where I can buy SMD.

    Or something else. Can I replace it with a PIC16LF18313-I / SN processor?
  • piotr_go
    DIY electronics designer
    No, not enough CLC.
    It must be PIC16F15313, any housing.
  • TomekMierzwa
    Level 9  
    RS works like a dream, connected with 3 wires to mikrotik, PPP / COM server there.
    Miami setup and everything works fine.

    Way to go!
  • piotr_go
    DIY electronics designer
    :)
    Record some video.

    It would be nice to do some PPP / SLIP WiFi "modem" on ESP32 / 8266.
  • TomekMierzwa
    Level 9  
    And on the PC, what did you transfer data with?
  • piotr_go
    DIY electronics designer
    I postpone the card. And when I created the partition, I don't remember it anymore. I think I used a virtual machine.